Solo usuarios registrados pueden comentar y agradecer, Logueate o Registrate

Autor Topic: [Problema] Conectar Base de Datos a otro VPS (Mu Core)  (Visto 3030 veces)

0 Miembros and 1 Guest are viewing this topic.

Offline Urko Posteado: June 20, 2017, 10:55:26 PM

  • 0 puntos por ventas
  • *
  • *
  • Rank: Puto amo
  • Posts: 353
  • Gracias recibida: 281
  • ar
Hola que tal! lo que quiero hacer es lo siguiente:
Quiero mudar a otro vps el xampp + la MuCore para poder sacarla del mismo VPS donde esta el servidor.
Configuro todo:
Code: [Select]
/*------------------------------------------*\
| Server Databases:                          |
|                                            |
|  0 : MuOnline [database]                   |
|  1 : MuOnline and Me_Muonline [databases]  |
\*------------------------------------------*/

$core['server_use_2_db'] = "0";

##############################################

/*-------------------------------------*\
| MUCore SQL Connection Type:           |
|                                       |
|  MSSQL : Connect using mssql_conect() |
|  ODBC : Connect using odbc            |
\*-------------------------------------*/

//$core['connection_type'] = "MSSQL";
$core['connection_type'] = "MSSQL";

#########################################

/*--------------------------------------------------*\
| MuOnline Database Connection Settings              |
|                                                    |
| $core['db_host'] : Database host address           |
| $core['db_name'] : Database name                   |
| $core['db_use'] : SQL Authentication user          |
| $core['db_password'] : SQL Authentication password |
\*--------------------------------------------------*/

$core['db_host'] = "xxxxxxxxxxx";
       
$core['db_name'] = "MuOnline";   
     
$core['db_user']= "sa";

$core['db_password'] = "xxxxxxxxxxx";

######################################################

/*------------------------------------------------------------------*\
| NOTE:                                                              |
| Edit this only if $core['server_use_2_db'] value is set to 1,      |
| this mean your server use MuOnline and Me_MuOnline databases.      |
|                                                                    |
| Me_MuOnline Database Connection Settings                           |
|                                                                    |
| $core['db_host2'] : Database host address                          |
| $core['db_name2'] : Database name                                  |
| $core['db_use2'] : SQL Authentication user                         |
| $core['db_password2'] : SQL Authentication password                |
\*------------------------------------------------------------------*/

$core['db_host2'] = "xxxxxxxxx";
       
$core['db_name2'] = "MuOnline";   
     
$core['db_user2']= "sa";

$core['db_password2'] = "xxxxxxxx";

Pero en el paso 2 me sale: Connection with MuOnline Database   Failed - Fix this.

Lo mas raro de todo esto es que instale el mu maker en el vps nuevo y me conecta a la base de datos del server.
Tengo el puerto 1433 abierto.

Tengo SQL 2000 (SIN EL SP4)

Gracias:


Offline AleCarolina #1 Posteado: June 20, 2017, 11:16:58 PM

  • DiseƱador
  • 0 puntos por ventas
  • *
  • Rank: Usuario activo
  • Posts: 75
  • Gracias recibida: 96
  • ve
Hola que tal! lo que quiero hacer es lo siguiente:
Quiero mudar a otro vps el xampp + la MuCore para poder sacarla del mismo VPS donde esta el servidor.
Configuro todo:
Code: [Select]
/*------------------------------------------*\
| Server Databases:                          |
|                                            |
|  0 : MuOnline [database]                   |
|  1 : MuOnline and Me_Muonline [databases]  |
\*------------------------------------------*/

$core['server_use_2_db'] = "0";

##############################################

/*-------------------------------------*\
| MUCore SQL Connection Type:           |
|                                       |
|  MSSQL : Connect using mssql_conect() |
|  ODBC : Connect using odbc            |
\*-------------------------------------*/

//$core['connection_type'] = "MSSQL";
$core['connection_type'] = "MSSQL";

#########################################

/*--------------------------------------------------*\
| MuOnline Database Connection Settings              |
|                                                    |
| $core['db_host'] : Database host address           |
| $core['db_name'] : Database name                   |
| $core['db_use'] : SQL Authentication user          |
| $core['db_password'] : SQL Authentication password |
\*--------------------------------------------------*/

$core['db_host'] = "xxxxxxxxxxx";
       
$core['db_name'] = "MuOnline";   
     
$core['db_user']= "sa";

$core['db_password'] = "xxxxxxxxxxx";

######################################################

/*------------------------------------------------------------------*\
| NOTE:                                                              |
| Edit this only if $core['server_use_2_db'] value is set to 1,      |
| this mean your server use MuOnline and Me_MuOnline databases.      |
|                                                                    |
| Me_MuOnline Database Connection Settings                           |
|                                                                    |
| $core['db_host2'] : Database host address                          |
| $core['db_name2'] : Database name                                  |
| $core['db_use2'] : SQL Authentication user                         |
| $core['db_password2'] : SQL Authentication password                |
\*------------------------------------------------------------------*/

$core['db_host2'] = "xxxxxxxxx";
       
$core['db_name2'] = "MuOnline";   
     
$core['db_user2']= "sa";

$core['db_password2'] = "xxxxxxxx";

Pero en el paso 2 me sale: Connection with MuOnline Database   Failed - Fix this.

Lo mas raro de todo esto es que instale el mu maker en el vps nuevo y me conecta a la base de datos del server.
Tengo el puerto 1433 abierto.

Tengo SQL 2000 (SIN EL SP4)

Pues debes poner la ip de tu vps la clave del sql  abrir el puerto 1433 de todas maneras checka aca si tienes los puertos abiertos http://www.puertosabiertos.com/es/escaner-de-puertos.htm saludos


Offline Urko #2 Posteado: June 20, 2017, 11:27:22 PM

  • 0 puntos por ventas
  • *
  • *
  • Rank: Puto amo
  • Posts: 353
  • Gracias recibida: 281
  • ar
Hola que tal! lo que quiero hacer es lo siguiente:
Quiero mudar a otro vps el xampp + la MuCore para poder sacarla del mismo VPS donde esta el servidor.
Configuro todo:
Code: [Select]
/*------------------------------------------*\
| Server Databases:                          |
|                                            |
|  0 : MuOnline [database]                   |
|  1 : MuOnline and Me_Muonline [databases]  |
\*------------------------------------------*/

$core['server_use_2_db'] = "0";

##############################################

/*-------------------------------------*\
| MUCore SQL Connection Type:           |
|                                       |
|  MSSQL : Connect using mssql_conect() |
|  ODBC : Connect using odbc            |
\*-------------------------------------*/

//$core['connection_type'] = "MSSQL";
$core['connection_type'] = "MSSQL";

#########################################

/*--------------------------------------------------*\
| MuOnline Database Connection Settings              |
|                                                    |
| $core['db_host'] : Database host address           |
| $core['db_name'] : Database name                   |
| $core['db_use'] : SQL Authentication user          |
| $core['db_password'] : SQL Authentication password |
\*--------------------------------------------------*/

$core['db_host'] = "xxxxxxxxxxx";
       
$core['db_name'] = "MuOnline";   
     
$core['db_user']= "sa";

$core['db_password'] = "xxxxxxxxxxx";

######################################################

/*------------------------------------------------------------------*\
| NOTE:                                                              |
| Edit this only if $core['server_use_2_db'] value is set to 1,      |
| this mean your server use MuOnline and Me_MuOnline databases.      |
|                                                                    |
| Me_MuOnline Database Connection Settings                           |
|                                                                    |
| $core['db_host2'] : Database host address                          |
| $core['db_name2'] : Database name                                  |
| $core['db_use2'] : SQL Authentication user                         |
| $core['db_password2'] : SQL Authentication password                |
\*------------------------------------------------------------------*/

$core['db_host2'] = "xxxxxxxxx";
       
$core['db_name2'] = "MuOnline";   
     
$core['db_user2']= "sa";

$core['db_password2'] = "xxxxxxxx";

Pero en el paso 2 me sale: Connection with MuOnline Database   Failed - Fix this.

Lo mas raro de todo esto es que instale el mu maker en el vps nuevo y me conecta a la base de datos del server.
Tengo el puerto 1433 abierto.

Tengo SQL 2000 (SIN EL SP4)

Pues debes poner la ip de tu vps la clave del sql  abrir el puerto 1433 de todas maneras checka aca si tienes los puertos abiertos http://www.puertosabiertos.com/es/escaner-de-puertos.htm saludos

Gracias por contestar. Esta todo eso, solo puse las "xxxx" de ejemplo.


Offline Intlock #3 Posteado: June 21, 2017, 07:28:44 AM

  • 0 puntos por ventas
  • *
  • Rank: Principiante
  • Posts: 11
  • Gracias recibida: 3
  • uy
Contrata el hosting de Zabino, o configura el mssql remoto en xampp!


Offline Urko #4 Posteado: June 21, 2017, 11:47:50 AM

  • 0 puntos por ventas
  • *
  • *
  • Rank: Puto amo
  • Posts: 353
  • Gracias recibida: 281
  • ar
Contrata el hosting de Zabino, o configura el mssql remoto en xampp!

"mssql remoto en xampp" como logro eso?


Offline Urko #5 Posteado: June 21, 2017, 08:32:08 PM

  • 0 puntos por ventas
  • *
  • *
  • Rank: Puto amo
  • Posts: 353
  • Gracias recibida: 281
  • ar
Problema solucionado. Tenia el Anti DDOS Guardian bloqueandome la conexiĆ³n del vps remoto. Por lo tanto no dejaba que se conectaran las db.


Solo usuarios registrados pueden comentar y agradecer, Logueate o Registrate


 

Related Topics

  Subject / Started by Replies Last post
3 Replies
2907 Views
Last post June 08, 2018, 10:49:50 PM
by jesusb
3 Replies
1416 Views
Last post March 31, 2019, 06:59:44 PM
by joacoRu
3 Replies
1226 Views
Last post May 12, 2020, 01:28:38 PM
by nescafe
1 Replies
574 Views
Last post March 02, 2022, 07:02:42 PM
by NERA
1 Replies
438 Views
Last post June 02, 2022, 08:29:58 PM
by ShinedowN